Skip to end of metadata
Go to start of metadata

Description

Enables usage of GfxBuilder on your Griffon application.

Installation

The current version of griffon-gfx-plugin is 0.6.1
To install just issue the following command

Warning

Icon

This plugin requires JDK6 to be installed, it will also constrain the running environment to JRE6 or above.

Usage

Refer to GfxBuilder's documentation to know more about the graphical nodes. This builder also enables the following nodes to be used from swing:

Node

Property

Type

Default

Required

Bindable

Notes

canvas
[GfxCanvas]

node

GfxNode

 

(error)

(error)

 

The following is an example of its usage (copy & paste it on SwingPad 0.5)

History

Version

Date

Notes

0.6.1

11-01-11

Updated to GfxBuilder 0.5.1

0.6

05-17-11

Release sync with Griffon 0.9.3

0.5

02-10-11

Release sync with Griffon 0.9.2

0.4

07-22-10

Release sync with Griffon 0.9

0.3.1

03-23-10

Updated to GfxBuilder 0.2.4

0.3

03-01-10

Upgraded to Griffon 0.3

0.2.3

12-09-09

Updated to GfxBuilder 0.2.3

0.2.2

11-15-09

Updated to GfxBuilder 0.2.2

0.2.1

09-09-09

Updated to GfxBuilder 0.2.1

0.2

08-04-09

Updated to GfxBuilder 0.2

0.1

07-26-09

Initial release

  • No labels