Skip to end of metadata
Go to start of metadata

We are pleased to announce the release of Gmock 0.8.0. Gmock is a mocking framework for Groovy focused on readable and concise tests.

This release provides the support for Groovy 1.6 but you actually need to use Groovy 1.6.1 as it fixes some bugs that was affecting GMock.

We took the benefit of Groovy 1.6 and AST to provide a @WithGMock annotation that you can use when you can't (or don't want) extends the GMockTestCase:

Please visit http://gmock.org or http://code.google.com/p/gmock/ for more information. Documentation: http://gmock.org/documentation/0.8.0

We are are now quickly approaching the 1.0 milestone and we would love to hear your feedback and suggestions.

The Gmock Devs

  • No labels