Skip to end of metadata
Go to start of metadata

Occasionally, there's a need to deprecate a plugin. Typically for one or more of the following reasons:

  • the functionality is obsolete.
  • It's no longer maintained by its authors and is buggy.
  • It's no longer maintained and not compatible with the latest versions of the SonarQube platform.

 

When a plugin is deprecated, the following steps will be followed:

  1. Notify the plugin author(s) of the reasons and timing of the deprecation. 
  2. Remove the plugin from the update center.
  3. Move the plugin listing from Plug-in Library to Deprecated Plugins.
  4. Move the plugin documentation page to the Deprecated Plugins section.

 

 

  • No labels