Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • maybe have goals for whole thing, and also in individual modules?
  • must run in order listed in metadata file
  • must allow stuff that command line allows, like "-D" switches and fully-qualified/partially-qualified goal names
  • the repo containing the archetype/catalog should automatically be included when searching for the plugin

other sidenote:

ARCHETYPE-276 doesn't get enough love.  "Allow archetypes to declare minimum version of maven-archetype-plugin they need."  Users need some indication when the archetype plugin they are using isn't new enough to support the archetype's ambitions.

...