Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Code Block
<dependency>
  <groupId>org.tynamo.security</groupId>
  <artifactId>tapestry-security-jpa</artifactId>
  <version>0.0.3<4</version>
</dependency>

The module doesn't require mandatory configuration. If you don't explicitly specify the realm and the type of principal to use with relationship-based security rules, the implementation will use the primary principal of the subject. You can explicitly configure the principal to use in the security check:

...