Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: added Gradle to Groovy 1.0 info just to make the page look better

...

Available in the Maven 1 and Maven 2 repositories.

GradleMavenExplanation
'groovy:groovy:x.y.z'

<groupId>groovy</groupId>
<artifactId>groovy</artifactId>
<version>1.0</version>

Treats Antlr and ASM as standard dependencies. Only useful if you happen to also use the same versions of these jars yourself as it will save you having two copies of these jars. Dependencies mandated for all optional parts of Groovy, e.g. AntBuilder, GroovyMBeans, etc.
'groovy:groovy-all:x.y.z'

<groupId>groovy</groupId>
<artifactId>groovy-all</artifactId>
<version>1.0</version>

Includes jarjar versions of Antlr and ASM. Allows you or your other dependencies (e.g. hibernate) to use other versions of these jars. Dependencies mandated for all optional parts of Groovy, e.g. AntBuilder, GroovyMBeans, etc.
'groovy:groovy-all-minimal:x.y.z'

<groupId>groovy</groupId>
<artifactId>groovy-all-minimal</artifactId>
<version>1.0</version>

Includes jarjar versions of Antlr and ASM. Does not include any optional dependencies.

For historical purposes, the releases candidates for 1.0 are also available by using the appropriate version instead of 1.0 in the above version tag.

...