Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 4.0

JDK 1.6 Problems

There are a number of outstanding jvm bugs with jdk1.6, predominantly NIO or NIO/SSL related. If you are experiencing io problems and are using jdk1.6, please consider using jdk1.5 instead. Here is a list of the known bugs that we have come across:

  1. http://jira.codehaus.org/browse/JETTY-567 (jetty has a workaround for this one since jetty-6.1.15)
  2. http://jira.codehaus.org/browse/JETTY-937
  3. http://bugs.sun.com/view_bug.do?bug_id=6693490
  4. http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6403933
  5. https://issues.apache.org/jira/browse/DIRMINA-678
Contact the core Jetty developers at www.webtide.com
private support for your internal/customer projects ... custom extensions and distributions ... versioned snapshots for indefinite support ... scalability guidance for your apps and Ajax/Comet projects ... development services from 1 day to full product delivery