Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 5.3

Riding high on the back of the Groovy 1.7 release, the Groovy-Eclipse is pleased to announce its own 2.0.0RC1 release. Over 50 issues have been addressed for this release and we consider this release high quality enough to be considered for release in early January, unless blocking bugs are found.

...

Info
titleGroovy-Eclipse RC1 update site

To install RC1, add the following URL to your Eclipse update manager:
http://dist.springsource.org/milestone/GRECLIPSE/e3.5/

Table of Contents
maxLevelstyle2disc
indent20px
stylemaxLeveldisc2

Better @Grab support

Until recently the use of @Grab to pull in source file dependencies was not recognized by groovy eclipse, resulting in a compilation error for the type that would have been located by following the Grab. Now they are being recognized. The @Grab referenced dependencies are added to the classpath used under the covers to build the project. Content assist is also possible for references to @Grab'd types. Grabbed dependencies are not currently reflected anywhere in the eclipse project metadata (ie. they are not seen in the classpath Eclipse manages for the project) - this may change in a future version of Groovy Eclipse.

...