Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 5.3

The startup scripts for AIX, HPUX and Solaris have been removed since release 2.7 are not packaged with SonarQube for licensing reasons. You must download the Java Service Wrapper release specific to your platform then :.

<install_directory> (below) refers to the path to the directory where the SonarQube distribution has been unzipped.

  1. Copy $JSW/lib/libwrapper.so to the directory $SONAR<install_HOMEdirectory>/bin/<platform>/lib
  2. Copy $JSW/bin/wrapper to the directory $SONAR<install_HOMEdirectory>/bin/<platform>
  3. Copy $JSW/bin/demoapp to the directory $SONAR<install_HOMEdirectory>/bin/<platform>. Rename it "sonar" (or "sonar.sh"), edit and set the variables APP_NAME and APP_LONG_NAME to "sonar", WRAPPER_CONF to "../../conf/wrapper.conf"
  4. Replace $SONARReplace <install_HOMEdirectory>/lib/wrapper-3.2.3.jar by $JSW/lib/wrapper.jar
  5. The script $SONAR<install_HOMEdirectory>/bin/<platform>/sonar is ready to start and stop the standalone server

 

Note
titleIssue with JRuby 1.6.6 / 1.6.7For versions prior to 4.0

Due to the following JRuby issue: https://jira.codehaus.org/browse/JRUBY-6494, the following line has to be adeed added in SONARQUBE_HOME/conf/wrapper.conf:

Code Block
languagenone
wrapper.java.additional.3=-Djruby.native.enabled=false