Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

There is now better ordering on the Java classpath of Groovy source folders when importing maven projects that user Groovy into Eclipse and STS. See GRECLIPSE-1222.

Also, we have updated the Groovy-Eclipse compiler plugin for Maven docs to be explicit about how to configure your extra source folders.

Compatibility

Groovy-Eclipse 2.6.0 includes Groovy 1.7.10 by default. Groovy 1.8.4 can be optionally installed. This version of Groovy-Eclipse is recommended to be installed on STS 2.8.1 or 2.9.0.M1, Eclipse 3.7.1 or 3.6.2. There are different update sites for Groovy-Eclipse targeting Eclipse 3.6 and 3.7 (see above).

...