Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Plugin

1.0.0

2.0.0

2.1.0

2.2.0

2.4.03.0.0

Sonar

2.0.1+

2.4+

2.4+

2.4+

3.0+3.4+

Eclipse

3.5.x, 3.6.x

3.5.x, 3.6.x

3.5.x, 3.6.x

3.5.x, 3.6.x, 3.7.x

3.6.x, 3.7.x, 4.1.x3.7.x, 4.2.x

Mylyn (optional)

3.2.0+ and requires Sonar 2.8+

3.2.0+ and requires Sonar 2.9+

3.6.0+3.8.2+

Supported Languages

Java

Java

Java

Java

Java

Java
C/C++
Python 

Installation

To install this plugin in the Eclipse IDE:

  1. Go to Help > Install New Software... This should display the Install dialog box.
  2. Paste the Update Site URL (http://dist.sonar-ide.codehaus.org/eclipse/) into the field Work with and press Enter. This should display the list of available plugins and components.


     
  3. Choose the component listed under Sonar: "Sonar Integration for Eclipse (Required)".
  4. Click Next. Eclipse will then check to see if there are any issues which would prevent a successful installation.
  5. Click Finish to begin the installation process. Eclipse will then download and install the necessary components.
  6. Once the installation process is finished, Eclipse will ask you if you want to restart the IDE. It's strongly recommended that you restart IDE.

...