Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Security

If you have set the security property 'sonar.forceAuthentication' to 'true', to run an analysis, it is now mandatory to set the 'sonar.login' and 'sonar.password' properties to an existing user.

Upgrade the Motion Chart Plugin

If it's already installed, then the Motion Chart plugin must be upgraded to version 1.5.

The property sonar.core.codeCoveragePlugin is deprecated

The property sonar.core.codeCoveragePlugin is deprected. Even if it's still supported, it should be replaced by the property sonar.java.coveragePlugin on Java projects. There are currently no new properties for other languages.

Note that the upgrade automatically converts the property when it's declared in General or Project Settings.