Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

At any time, to run another local analysis, right-click on the project, then select Sonar > Run Local Analysis:

...

Violations View (displays local or remote information depending on the selected mode)

The Problems Violations view displays the list of violations of the selected resource (project, file, etc.):

Image Removed

 

Image Added

To refresh violations of resources from remote server, click on the Refresh button.

This view can be displayed by going to Window > Show View > Other... > Sonar > Violations.

Note that Problems and Markers views also displays Sonar violations.

Web View (displays remote information only)

...

This web page can also be used to access information and services (Clouds, Hotspots, etc.) that are not available in Sonar Eclipse.

This view is automatically displayed when clicking on Sonar > Open in Sonar server. It can also be displayed by going to Window > Show View > Other... > Sonar > Web.