Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: PMD plugin version 2.2
Wiki Markup
{iframe:src=http://update.sonarsource.org/plugins/pmd.html|width=700|height=250|frameborder=0}
Your browser does not support iframes.
{iframe}

Description / Feature

This plugin is included in the Java Ecosystemprovides coding rules from PMD.It uses 

PMD

...

1112.34

SonarQube Java Plugin

2.02.112.2

PMD

4.34.345.341.31

Include Page
Include - Plugin Installation
Include - Plugin Installation

Usage

In the quality profile, activate some rules from PMD and run an analysis on your project.

Set the sonar.java.source property to tell PMD which version of Java your source code complies to. The default value is 1.5. Possible values: 1.4, 1.5 or 5, 1.6 or 6, 1.7 or 7. Since version 2.2 of the plugin, this property can also be set to 1.8 or 8.