Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

To switch from one mode to another, right-click on the project, then select Sonar > Mode > Remote or Local:

Image RemovedImage Added

When switching to the Local mode, a local analysis will be run automatically.

At any time, to run another local analysis, right-click on the project, then select Sonar > Run Local Analysis:

Image RemovedImage Added

Local Analysis Parameters

...

  • Right-click on the project in the Project Explorer, and then Properties > Sonar
  • This date can be displayed on the navigation views, like the Project explorer or the Navigator. This option is not active by default. To activate it, go to Window > Preferences > General > Appearance > Label Decorations and check Sonar Analysis Date Decorator:

Image RemovedImage Added

Sonar Issues View (displays local or remote information depending on the selected mode)

The Sonar Issues view displays the list of issues of the selected resource (project, file, etc.):

Image RemovedImage Added

To refresh the list of issues on the project, click on the Refresh button.

...

This web page can also be used to access information and services (Clouds, Hotspots, etc.) that are not available in Sonar Eclipse.

Image RemovedImage Added

This view is automatically displayed when clicking on Sonar > Open in Sonar server. It can also be displayed by going to Window > Show View > Other... > Sonar > Sonar Web Browser.

...