Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Info

This page documents how to browse SonarQube TM in Eclipse for versions 3.2+.

For versions prior to 3.2, browse this page.

...

This is the default mode. Information showed in the remote mode is coming from a remote SonarQubeTM serverSonarQubeserver. This means that this information has been computed during the latest analysis on that server.

...

  • Parameters defined in the SonarQube TM Web UI
  • Parameters set in the pom.xml file (for Maven projects only, with the m2e connector installed) will override parameters defined in the UI
  • Parameters defined in Eclipse will override  parameters defined in the pom file (go to Window > Preferences > Sonar > Local analysis properties)
  • Parameters defined at project level in Eclipse will override parameters defined at Eclipse level (right click on the project and go to Properties > Sonar > Local analysis properties)

...

This web page can also be used to access information and services (Clouds, Hotspots, etc.) that are not available in SonarQube TM Eclipse.

This view is automatically displayed when clicking on Sonar > Open in Sonar server. It can also be displayed by going to Window > Show View > Other... > Sonar > Sonar Web Browser.

...