Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 4.0
Code Block
<!--
 | Contains plugin version information related to which version of a particular plugin to use,
 | when and how to update plugins, and which versions of a plugin have already been declined for
 | update.
 |-->
<pluginRegistry>

  <!--
   | Specifies how often to check for plugin updates. Valid values are: never, always,
   | interval:XXX. For the interval specification, XXX denotes a terse interval specification,
   | such as 4h. Where h=hours, m=minutes, d=days, w=weeks. The interval period should be
   | specified in descending order of granularity, like this: '[n]w [n]d [n]h [n]m'. Any omitted
   | level of granularity will be assumed to be a zero value.
   |
   | Default: never
   |-->
  <updateInterval />

  <!--
   | Specifies whether the user should be prompted to update plugins.
   |-->
  <autoUpdate />

  <!--
   | Whether to resolve plugin versions using LATEST metadata.
   |-->
  <checkLatest />

  <!--
   | Policies for updating plugins
   |-->
  <plugins>

    <!--
     | Policy for updating a single plugin.
     |
     | Multiplicity: 0 or more
     |-->
    <plugin>

      <!--
       | Required: Yes
       |-->
      <groupId />

      <!--
       | Required: Yes
       |-->
      <artifactId />

      <!--
       | [format: yyyy-MM-dd.HH:mm:ss Z] Specifies the date/time at which this plugin was last checked.
       |-->
      <lastChecked />

      <!--
       | The current version of this plugin, to be used until the appropriate update actions happen.
       |-->
      <useVersion />

      <!--
       | The list of versions for this plugin that the user declined to "install"
       |-->
      <rejectedVersions>

        <!--
         | Multiplicity: 0 or more
         |-->
        <rejectedVersion />

      </rejectedVersions>

    </plugin>

  </plugins>

</pluginRegistry>