Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Note

This page documents version 3.3 of the SonarQube Eclipse plugin. For prior versions, click here.

SonarQube Issues View

Running an Analysis

Browsing the Results

Four different views are available to browse the quality of your projects:

  • SonarQube Issues that list the issues on the selected component
  • SonarQube Issue Editor to review the issue
  • SonarQube Rule Description to get the detailed description of the rule that is violated
  • SonarQube Web Browser

Image Added

SonarQube Issues

The SonarQube Issues view displays the list of issues of the selected component (project, module, file, etc.):

Image Removed

. To display this view, go to Window > Show View > Other... > SonarQube > SonarQube IssuesProblems and Markers views also display issues.

Issues are flagged in the source code viewer. New issues (compared to the latest version on the SonarQube server) are highlighted in yellow. This allows you to focus on the new issues that you have introduced.

Image Added

You can add/remove/order columns, group issues (by severitiesseverity, new issues only, ...), filter issues (new issues only, issues , assigned to me, ...), sort (by assignee, ...), etc.

Note that "Resolved" issues are not displayed.This view can be displayed by going

SonarQube Issue Editor

This view allows you to review the selected issue (add comments, confirm it, plan it, etc.) the same way you would do it through the web interface. To display this view, go to Window > Show View > Other... > Sonar > Sonar IssuesProblems and Markers views also display issues.

SonarQube Web Browser View

The Web view displays the main project dashboard (for project) or the component viewer (for class or file).

This web page can also be used to access information and services (Clouds, Hotspots, etc.) that are not available in SonarQube Eclipse.

Image Removed

This view SonarQube > SonarQube Issue Editor.

Image Added

Note that it is not possible to review new issue that you have introduced.

SonarQube Rule Description

This view allows you to access the detailed description of the coding rule of the selected issue. To display this view, go to Window > Show View > Other... > SonarQube > SonarQube Rule Description.

Image Added

SonarQube Web Browser

This view allows you to access the SonarQube web interface. This view is automatically displayed when clicking on Sonar SonarQube > Open in Sonar SonarQube server. It can also be displayed by going to Window > Show View > Other... > Sonar > Sonar Web Browser.

 Image Added

 

Local Analysis Parameters

...

  • Right-click on the project in the Project Explorer, and then Properties > Sonar
  • This date can be displayed on the navigation views, like the Project explorer or the Navigator. This option is not active by default. To activate it, go to Window > Preferences > General > Appearance > Label Decorations and check Sonar Analysis Date Decorator:

FAQ

No issues are displayed

...

It happens when the source folders are not properly set in Eclipse.

...