Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Note

This page documents version 3.3 of the SonarQube Eclipse plugin. For prior versions, click here.

Running an Analysis

Browsing the Results

Four different views are available to browse the quality of your projects:

  • SonarQube Issues that list the issues on the selected component
  • SonarQube Issue Editor to review the issue
  • SonarQube Rule Description to get the detailed description of the rule that is violated
  • SonarQube Web Browser

SonarQube Issues

The SonarQube Issues view displays the list of issues of the selected component (project, module, file, etc.). To display this view, go to Window > Show View > Other... > SonarQube > SonarQube IssuesProblems and Markers views also display issues.

...

Note that "Resolved" issues are not displayed.

SonarQube Issue Editor

This view allows you to review the selected issue (add comments, confirm it, plan it, etc.) the same way you would do it through the web interface. To display this view, go to Window > Show View > Other... > SonarQube > SonarQube Issue Editor.

...

Note that it is not possible to review new issue that you have introduced.

SonarQube Rule Description

This view allows you to access the detailed description of the coding rule of the selected issue. To display this view, go to Window > Show View > Other... > SonarQube > SonarQube Rule Description.

SonarQube Web Browser

This view allows you to access the SonarQube web interface. This view is automatically displayed when clicking on SonarQube > Open in SonarQube server. It can also be displayed by going to Window > Show View > Other... > Sonar > Sonar Web Browser.

 

 

Local Analysis Parameters

Parameters to configure local analysis can be set in various places. Here is the hierarchy of parameters:

...

Info
titleExcluding Plugins

Some plugins (useless for a local analysis) can be skipped while performing a local analysis thanks to the sonar.dryRun.excludePlugins property (Settings > Configuration > General Settings > General > General).

The default value is 'devcockpit,pdfreport,report,scmactivity,views'. For example, to skip the Build Stability plugin (due to https://jira.codehaus.org/browse/SONARIDE-346), set the property to 'devcockpit,pdfreport,report,scmactivity,views,buildstability'.

Last Analysis Date

There are two ways to know when the last analysis was run on a project:

  • Right-click on the project in the Project Explorer, and then Properties > Sonar
  • This date can be displayed on the navigation views, like the Project explorer or the Navigator. This option is not active by default. To activate it, go to Window > Preferences > General > Appearance > Label Decorations and check Sonar Analysis Date Decorator:

FAQ

No issues are displayed

It happens when the source folders are not properly set in Eclipse.

...