Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 5.3

Motivation:

Supporting the new xml parser

Contact:

Justin Deoliveira

Tracker:

http://jira.codehaus.org/browse/GEOT-XXXX

Tagline:

Excerpt

This page represents the current plan; for discussion please check the tracker link above.

Description

Moving the new xml parser from unsupported to supported. All the xml modules meet the following criteria for supported modules:

(tick)

Visibility

Used extensively as part of wfs 1.1 support for GeoServer

(tick)

IP Check

(tick)

Test Coverage

(tick)

User Documentation

GEOTDOC:05 XML Parsing and Encoding

The proposal involves finding a home in supported space for the following unsupported modules. The proposed moves are:

  • unsupported/xml-xsd ==> library/xml **
  • unsupported/xml-gml2 ==> extension/xml/gml2
  • unsupported/xml-gml3 ==> extension/xml/gml3
  • unsupported/xml-sld ==> extension/xml/sld
  • unsupported/xml-filter ==> extension/xml/filter

** Involves lumping in xml-xsd with the current xml module

Status

Section
Column
width60%

This proposal is under construction.

Voting has not started yet:

Column
Wiki Markup
{dynamictasklist:Impediments}{dynamictasklist}

Resources

Section
Column
width60%
Attachments
uploadtrue
Column
Children Display

Tasks

The

API Changes

No api changes

Documentation Changes

No documentation changes