Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 14 Next »

So , the shell not enough? Fancy a bit of IDE action ?
Well you're in the right place.

Here you will find the latest information regarding the groovy Eclipse plugin, some instructions to build or download, install and test ...
Check also http://wiki.codehaus.org/groovy/HackingEclipsePlugin

Build the latest version from CVS

  1. Check out /groovy/ide/groovy-eclipse/Groovy and /groovy/ide/groovy-eclipse/GroovyEclipse from CVS (see here http://groovy.codehaus.org/cvs-usage.html for CVS infos) into separate Eclipse projects. Just use simple check-outs, CVS already contains all the informations Eclipse needs to create the projects properly (i.e. .project and .classpath and other files)
  2. Select the GroovyEclipse project in the pacakge explorer view, right mouse click, and a pop-up window called Export shows up.
  3. In the Export pop-up, select "Deployable plug-ins and fragments", click next, then:
    • In the Available Plug-ins and Fragments list, select "org.codehaus.groovy", "org.codehaus.groovy.eclipse"
    • In Export Options/Deploy as, Select "as single Zip file"
    • In the Destination, enter or browse for a file name
    • Click on Finish, and you are done.

Downloads for the lazy

  • latest build: 2004-09-23 off CVS.
    I tested that build with Eclipse 3.0.1 and it worked perfectly
    (I just had to comment one weird line of code in org/codehaus/groovy/eclipse/model/AddErrorMarker.java line 81 which just was : unit. ???, but then everything went fine) -pombredanne pombredanne
  • Download at : http://sf.net/projects/nexb

Install and Test

The zip file you just created (or downloaded) is now just like any other plug-in zip file, that can be unzipped under the eclipse root directory.
To install and test the plug-in:

  1. Open the zip file and exxtract its content to the eclipse root directory.
    You can check that two folders have been created under eclipse/plugin:
    org.codehaus.groovy.eclipse_1.0.0 and org.codehaus.groovy_1.0.0
  2. Restart Eclipse to install the Grrovy plug-in
  3. For quick test of the plug-in:
    • Create a new Java project, right mouse-click on the src folder, and select New/Other/Groovy/Groovy Class
    • Create a new Groovy class called GTest,
    • or alteranively create a new plain file and give it the name of the class you want to create plus the .groovy extension
    • When prompted "Add runtime groovy support and auto-build to project?" , click Yes! (You may be prompted that question twice... always say Yes!)
    • You can paste the following snippet into the GTest.groovy editor:
      GTest.groovy
    • In the Project Explorer, select GTest.groovy, then right mouse-click and Run/Run
    • In the Run pop-up, select Groovy in the list of configurations, then click New, and click the Search button to search for the Main Class.
      The GTest class should appear in the list of Groovy classes to run. Select it and clieck OK.
    • Click Apply, then Run... check your console view, it should read Rod, Phil...
      YOU ARE REALLY DONE! (thumbs up) (big grin) (smile) (thumbs up)

Eclipse Version compatibility

The plug-in has been reported to work with:

  • Eclipse 3.0
  • Eclipse 3.0.1
  • Eclipse 3.1 M1 (except that only libraries seem to be supported as classpath entries, not other projects or java code in the same project's source folder)
  • No labels