Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 91 Next »

The purpose of the Groovy Eclipse plugin is to promote the Groovy platform and ecosystem as a viable and productive development environment for Java developers working in the Eclipse SDK.

The Groovy Eclipse Plugin allows you to edit, compile and run both groovy scripts and classes from the Eclipse SDK.

(warning) Note that the plugin is work in progress. You can check the current status of the plugin here: issues and bugs

Eclipse version compatibility

(error) Eclipse 3.0 : not working; there are dependencies to the 3.1 AP
(error) Eclipse 3.1 : not working with version 1.0.1 of the plugin. Works with version 1.0.0.20070118
(tick) Eclipse 3.2 : working
(tick) Eclipse 3.3 : working
(tick) Eclipse 3.4 : working (initial simple testing seems to work, more thorough testing still required)

Quick Start

For the installation of the Groovy Eclipse Plugin follow this PDF presentation.

The "Hello World" screen cast shows you how to write a Groovy "Hello World" application using Eclipse.

Installation

There are two ways to install the plugin, one is the preferred way through the Update Site and second is manual installation from a zip archive.

Update Site

The update site containing the most recent release is here: http://dist.codehaus.org/groovy/distributions/update/

  • Go to: Help -> Software Updates -> Find and Install -> Search For New Features
  • Click on New Remote Site
  • Enter a name (eg: Groovy) in the Name field
  • Copy the URL from above into the URL field and press OK
  • Check the new Groovy repository and press finish
  • Under Select the Features to Install check the Groovy check box (be sure to get the latest version) and press Next
  • Accept the agreement and press Next
  • If the default location looks okay press Finish (this will download the plugin)
  • If you get a warning that the plugin is unsigned click Install or Install All

This should download and install the Groovy plugin.  It may require a restart of Eclipse to make sure it is loaded okay.

If you're interested in trying the latest development version, the update site is: http://dist.codehaus.org/groovy/distributions/updateDev/

The head version of groovy-eclipse is builded on a CI Server at the HSR (University of Applied Sciences Rapperswil). The update site is: http://groovy.ifs.hsr.ch/GroovyRefactoring/OfficialUpdateSite/

New! Developement version of the Plugin with Refactoring support Eclipse Plugin Refactoring

From Zip Archive

It is possible to access a zip archive that can be expanded into your eclipse installation from: http://dist.codehaus.org/groovy/distributions/update/GroovyEclipse.zip.

Create a Groovy Project

To create a basic Groovy project in Eclipse perform the following steps:

  • Go to: File -> New -> Project
  • Select Java Project and press Next
  • In the Project Name field enter the name of your project (GroovyJava for this example)
  • Under Project Layout select Create separate source and output folders and press Finish
  • In the Package Explorer find the newly created project, right click, and select Groovy -> Add Groovy Nature

So far you should have a src folder, a bin-groovy folder, and several libraries. There is also a bin folder that was created by Eclipse, but is hidden due to exclusion filters. The next steps are needed to make the bin-groovy folder the default output folder, and to connect it to the src folder so that the debugger will know where to find the associated source and classes:

  • In the Package Explorer, right click on the "GroovyJava" project, and select: Build Path -> Configure Build Path
  • Select the Source tab and then use the Browse button to change the Default Output Folder from bin to bin-groovy
  • Press OK, OK

This will expose the bin folder in the Package Explorer. I'm not sure why the plugin creates a bin-groovy directory. Perhaps there are other "bin" files that are best kept separate from the Groovy classes, or perhaps one of the original versions of Eclipse didn't create a "bin" directory automatically. Some day when someone has a clear idea of the usefulness of this, or lack thereof, we can clean up my instructions.

Download and build from Subversion

This section is for those who want to do development work on the Eclipse plugin.  More specific information regarding the wish-list and standards can be found at Eclipse Plugin Development.  You may also want to join the groovy-eclipse-dev mailing list by subscribing here - http://xircles.codehaus.org/lists/eclipse-plugin-dev@groovy.codehaus.org.

See the Codehaus Subversion page for general information on how to access the repository.
See the Subversion home page if you are new to Subversion in general.
To simply view the plugin code, use FishEye.

The plugin source contains Groovy source files. You will need to be able to compile Groovy in order to build the plugin. The easiest method is to download the released plugin from the update site (http://dist.codehaus.org/groovy/distributions/update/) or the development version of the plugin from the development update site (http://dist.codehaus.org/groovy/distributions/updateDev/).

The plugin modules depend on TestNG. Instructions for downloading the TestNG Eclipse plugin are on the TestNG Download page.

Checkout the plugin modules by running the following command:

Each module already contains all the information Eclipse needs to create the project properly (i.e. .project, .classpath and other files).  From Eclipse, "Import" the projects into your workspace.

Detailed description of how to checkout using the Eclipse Subclipse plugin:

  1. Select the Window -> Open Perspective->Other -> SVN Repository Exploring.
  2. In the context menu of the SVN Repository pane, select New Repository Location
  3. Enter the following URL: http://svn.codehaus.org/groovy/
  4. Navigate to /trunk/groovy/ide/groovy-eclipse and select all of the projects under trunk/groovy/ide/groovy-eclipse.
  5. Right-click to get the context menu and select Check out (not Check out as)
  6. Now you should have all of the groovy-eclipse projects in your package explorer view

Testing the plugin

It might be useful to test the plugin before you use it in your main eclipse installation. There are two Eclipse test projects called GroovyEclipseTests and org.codehaus.groovy.eclipse.core.test. To run them right-click on the project and select Run As>JUnit Plug-in Test.

Building the Update Site

To build the update site for use with your main eclipse installation follow these simple instructions:

  1. Open the site.xml file in the GroovySite project.
  2. Click Build All button.
  3. This will build an update site under the GroovySite project.  

Installing the update site that you built

The update site you just created can now be installed with the Eclipse update manager.  You can install the Groovy feature by following the instructions in the Update Site section above, but using a Local Site pointing to the GroovySite directory that you just built, instead of a Remote Site.

Filing an issue (bug report):

http://jira.codehaus.org/secure/BrowseProject.jspa?id=10242

under the "GRECLIPSE" category

  • No labels