Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 73 Next »

The Groovy Eclipse Plugin allows you to edit, compile and run groovy scripts and classes.

(warning) Note that the plugin is work in progress. You can check the current status of the plugin here: issues and bugs

Eclipse version compatibility

(error) Eclipse 3.0 : not working; there are dependencies to the 3.1 AP
(error) Eclipse 3.1 : not working with version 1.0.1 of the plugin. Works with version 1.0.0.20070118
(tick) Eclipse 3.2 : working
(tick) Eclipse 3.3 : working - (based on minimal initial testing)

Update Site

The update site containing the most recent release is here: http://dist.codehaus.org/groovy/distributions/update/

  • Go to: Help -> Software Updates -> Find and Install -> Search For New Features
  • Click on New Remote Site
  • Enter a name (eg: Groovy) in the Name field
  • Copy the URL from above into the URL field and press OK
  • Check the new Groovy repository and press finish
  • Under Select the Features to Install check the Groovy check box (be sure to get the latest version) and press Next
  • Accept the agreement and press Next
  • If the default location looks okay press Finish (this will download the plugin)
  • If you get a warning that the plugin is unsigned click Install or Install All

This should download and install the Groovy plugin.  It may require a restart of Eclipse to make sure it is loaded okay.

If you're interested in trying the latest development version, the update site is: http://dist.codehaus.org/groovy/distributions/updateDev/

Create a Groovy Project

To create a basic Groovy project in Eclipse perform the following steps:

  • Go to: File -> New -> Project
  • Select Java Project and press Next
  • In the Project Name field enter the name of your project (GroovyJava for this example)
  • Under Project Layout select Create separate source and output folders and press Finish
  • In the Package Explorer find the newly created project, right click, and select Groovy -> Add Groovy Nature

So far you should have a src folder, a bin-groovy folder, and several libraries. There is also a bin folder that was created by Eclipse, but is hidden due to exclusion filters. The next steps are needed to make the bin-groovy folder the default output folder, and to connect it to the src folder so that the debugger will know where to find the associated source and classes:

  • In the Package Explorer, right click on the "GroovyJava" project, and select: Build Path -> Configure Build Path
  • Use the Browse button to change the Default Output Folder from bin to bin-groovy
  • Press OK, OK

This will expose the bin folder in the Package Explorer. I'm not sure why the plugin creates a bin-groovy directory. Perhaps there are other "bin" files that are best kept separate from the Groovy classes, or perhaps one of the original versions of Eclipse didn't create a "bin" directory automatically. Some day when someone has a clear idea of the usefulness of this, or lack thereof, we can clean up my instructions.

Download and build from Subversion

This section is for those who want to do development work on the Eclipse plugin.  More specific information regarding the wish-list and standards can be found at Eclipse Plugin Development.

See the Codehaus Subversion page for general information on how to access the repository.
See the Subversion home page if you are new to Subversion in general.
To simply view the plugin code, use FishEye.

Checkout the plugin modules by running the following command:



Each module already contains all the information Eclipse needs to create the project properly (i.e. .project, .classpath and other files).  From Eclipse, "Import" the projects into your workspace.

Detailed description of how to checkout using the Eclipse Subclipse plugin:

  1. Select the Window -> Open Perspective->Other -> SVN Repository Exploring.
  2. In the context menu of the SVN Repository pane, select New Repository Location
  3. Enter the following URL: http://svn.codehaus.org/groovy/
  4. Open these folders:/trunk/groovy/ide/groovy-eclipse/GroovyEclipse and /trunk/groovy/ide/groovy-eclipse/GroovyBrowsing
  5. Right-click to get its context menu and select Check out (not Check out as)
  6. Now you should have two projects called GroovyEclipse and GroovyBrowsing in your package explorer view

Testing the plugin

It might be useful to test the plugin before you export it and use it in your main eclipse installation. To accomplish this

  1. Simply select or double click the file called plugin.xml from the GroovyEclipse project. This should bring up an editor for the plugin description; the first page should be called Overview.
  2. In this page, select the link Launch an Eclipse application. This should start a new Eclipse instance in which you have no projects.
    • You may optionally select Launch an Eclipse application in Debug mode. If you do, you will be able to edit the plugin code, and have your changes take effect immediately (hot code replacement). This is very useful if you are developing things and want to test your changes without stopping and restarting the runtime workbench. Note that there are certain limitations to this; it does not work with changing the plugin.xml file.
  3. Create a new Java project and configure the project (perhaps adding a package first).
  4. Create a new Groovy class named GTest. Do this on the context (right mouse button) menu of the package in which you want your groovy class; like so: New -> Other -> Groovy -> Groovy Class.
  5. You will be asked if you wish to "Add runtime groovy support and auto build to project?". Say yes.
  6. Fill in the groovy code of your desire, for example something like this:
    GTest.groovy

Running the example above

  1. In the Project Explorer, select GTest.groovy, then right mouse-click and Run -> Run
  2. In the Run pop-up, select Groovy in the list of configurations, then click New, and click the Search button to search for the Main class.
    The GTest class should appear in the list of Groovy classes to run. Select it and click OK.
  3. Click Apply, then Run... check your console view, it should read Rod, Phil...

(tick) THAT'S IT!

Exporting the plugin

To export the plugin for use with your main eclipse installation follow these simple instructions:

  1. Select the plugin.xml file in the GroovyEclipse project.
  2. Select the link Export Wizard
  3. In Available Plug-ins and Fragments, check both org.codehaus.groovy.eclipse and org.codehaus.groovy.eclipse.codebrowsing
  4. In Export destination -> Archive file: enter a filename, e.g. org.codehaus.groovy.eclipse_1.0.0.zip
  5. (Optionally, you may wish to check the 'Package plug-ins as individual jar archives' option under Export options. This is a new export format used by Eclipse 3.1, however the old format also works fine with Eclipse 3.1.)
  6. Click Finish, and you are done.

Installing the plugin

The zip file you just created is now just like any other plugin zip file, that can be unzipped under the eclipse root directory. To install the plugin:

  1. Shutdown Eclipse
  2. Open the zip file and extract its content to the eclipse root directory. You should check that either a folder or jar has been created under eclipse/plugin:
    • Either a directory org.codehaus.groovy.eclipse_1.0.0
    • or a jar file org.codehaus.groovy.eclipse_1.0.0.jar if you checked the 'Package plug-ins as individual jar archives' option when exporting the plugin.
  3. Restart Eclipse to install the Groovy plugin
  • No labels