Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 37 Next »

Table of Contents

Icon

Local and Remote Mode

When using Sonar in Eclipse, two modes are available:

Remote Mode

This is the default mode. Information showed in the remote mode is coming from a remote Sonar server. This means that this information has been computed during the latest analysis on that server.

Thus, you will not see violations introduced in the code that you just added or changed.

Local Mode

When switching to the local mode, information displayed is coming from the latest local analysis.

Thus, you can see the violations introduced in the code that you just added or changed.

Switch from One Mode to Another

To switch from one mode to another, right-click on the project, then select Sonar > Mode > Remote or Local:

When switching to the Local mode, a local analysis will be run automatically.

At any time, to run another local analysis, right-click on the project, then select Sonar > Run Local Analysis:

Violations View (displays local or remote information depending on the selected mode)

The Violations view displays the list of violations of the selected resource (project, file, etc.):

To refresh violations of resources from remote server, click on the Refresh button.

This view can be displayed by going to Window > Show View > Other... > Sonar > Violations.

Note that Problems and Markers views also displays Sonar violations.

Web View (displays remote information only)

The Web view displays the main project dashboard (for project) or the resource viewer (for class or file).

This web page can also be used to access information and services (Clouds, Hotspots, etc.) that are not available in Sonar Eclipse.

This view is automatically displayed when clicking on Sonar > Open in Sonar server. It can also be displayed by going to Window > Show View > Other... > Sonar > Web.

  • No labels