The Groovy-Eclipse team is proud to announce the release of Groovy-Eclipse 2.8.0. This is a service refresh of Groovy-Eclipse and it now contains support for the 2.0.7 and 2.1.5 Groovy compilers as well as Eclipse 4.2.
You can use the following update sites to install this release:
The Groovy 2.1 compiler is not installed by default. If you want to install it, you can do so from the Extra Compilers category in the update site.
And a zipped version of the update site is available at:
Upgrade to Groovy 2.1.5
Groovy-Eclipse now contains Groovy 2.1.5 as an optional add-on from the update site. See Compiler Switching within Groovy-Eclipse for more information on how to do this.
groovy-eclipse-compiler now requires explicit groovy-eclipse-batch dependency
The 2.8.0-01 release of the groovy-eclipse-compiler (the Eclipse-based Groovy compiler plugin for Maven) has been released simultaneously with Groovy-Eclipse 2.8.0. The groovy-eclipse-compiler artifact is a small wrapper that implements the compiler plugin API. Actual compilation is delegated to the groovy-eclipse-batch compiler. There is a version of the groovy-eclipse-batch artifact for each Groovy version. Prior to 2.8.0-01, consumers did not need to explicitly specify a groovy-eclipse-batch version in the pom. In this case, the most recent version of groovy-eclipse-batch was used. However, this lead to problems when a new version of groovy-eclipse-batch was released and the behavior of builds would change. Now, the version must be explicit and this ensures stability of builds over time. For example, running with the following will produce an error message:
The error message will look something like this:
And adding a dependency to the maven-compiler-plugin like this, will ensure the compile is successful:
Groovy-Eclipse 2.8.0 uses Groovy 2.0.7 by default and comes with Groovy 1.8.6 can be optionally enbled. installed through the extra compilers section on the Groovy-Eclipse update site.
This is the last release with Groovy 1.7 support. If you want to install Groovy 1.7, then you must de-select Group items by category in the install manager:
This version of Groovy-Eclipse comes pre-installed in the Groovy/Grails Tool Suite version 3.3.0. It is also tested on Eclipse versions 3.7.2, 3.8.2, 4.2.2, and 4.3.
There are several notable compatibility changes with the 2.8.0-01 release of the groovy-eclipse-compiler:
- Requires maven-compiler-plugin 3.0 or greater
- Requires plexus-compiler-api 2.2 or greater
- Requires explicit dependency on groovy-eclipse-batch artifact (see above)