Full documentation for SonarQube has moved to a new location: http://docs.sonarqube.org/display/SONAR

Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 67 Next »

Table of Contents

Icon

This page documents version 3.3 of the SonarQube Eclipse plugin. For prior versions, click here.

SonarQube Issues View

The SonarQube Issues view displays the list of issues of the selected component (project, file, etc.):

You can add/remove columns, group issues (by severities, ...), filter issues (new issues only, issues, assigned to me, ...), sort (by assignee, ...), etc.

Note that "Resolved" issues are not displayed.

This view can be displayed by going to Window > Show View > Other... > Sonar > Sonar IssuesProblems and Markers views also display issues.

SonarQube Web Browser View

The Web view displays the main project dashboard (for project) or the component viewer (for class or file).

This web page can also be used to access information and services (Clouds, Hotspots, etc.) that are not available in SonarQube Eclipse.

This view is automatically displayed when clicking on Sonar > Open in Sonar server. It can also be displayed by going to Window > Show View > Other... > Sonar > Sonar Web Browser.

Local Analysis Parameters

Parameters to configure local analysis can be set in various places. Here is the hierarchy of parameters:

  • Parameters defined in the SonarQube Web UI
  • Parameters set in the pom.xml file (for Maven projects only, with the m2e connector installed) will override parameters defined in the UI
  • Parameters defined in Eclipse will override  parameters defined in the pom file (go to Window > Preferences > Sonar > Local analysis properties)
  • Parameters defined at project level in Eclipse will override parameters defined at Eclipse level (right click on the project and go to Properties > Sonar > Local analysis properties)

Excluding Plugins

Icon

Some plugins (useless for a local analysis) can be skipped while performing a local analysis thanks to the sonar.dryRun.excludePlugins property (Settings > Configuration > General Settings > General > General).

The default value is 'devcockpit,pdfreport,report,scmactivity,views'. For example, to skip the Build Stability plugin (due to https://jira.codehaus.org/browse/SONARIDE-346), set the property to 'devcockpit,pdfreport,report,scmactivity,views,buildstability'.

Last Analysis Date

There are two ways to know when the last analysis was run on a project:

  • Right-click on the project in the Project Explorer, and then Properties > Sonar
  • This date can be displayed on the navigation views, like the Project explorer or the Navigator. This option is not active by default. To activate it, go to Window > Preferences > General > Appearance > Label Decorations and check Sonar Analysis Date Decorator:

FAQ

No issues are displayed in remote mode

It happens when the source folders are not properly set in Eclipse.

Let's take the C/C++ project sample for instance. When you import it into Eclipse, by default the source folder is set to /cpp-sonar-runner (and not to /cpp-sonar-runner/src):

Therefore, SonarQube will try to retrieve data from files whose fully qualified names are src/BiggestUnInt.cc, src/HelloWorld.cpp, etc. It will find none as the fully qualified names in SonarQube are BiggestUnInt.cc, HelloWorld.cpp, etc. (without "src/"):

Hence, you won't get any issue displayed in remote mode in Eclipse.

But if you set the source folder to cpp-sonar-runner/src instead:

you will get issues displayed:

  • No labels