Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 180 Next »

Compatibility Matrix

Plugin

3.1.13.3

SonarQube

3.4.0 => 3.5.13.6+

Eclipse

3.7.x, 3.8.x, 4.2.x, 4.3.x
(Indigo, Juno, Kepler)

3.7.x, 3.8.x, 4.2.x, 4.3.x
(Indigo, Juno, Kepler)

Mylyn

3.8.2+No longer needed

Supported Languages/Plugins

Java
C/C++ (SonarSource)
Python 

Java
C/C++ (SonarSource)
Python 

Installation

If a previous version of SonarQube Eclipse is already installed, you can update it. Go to Help > Check for Updates.

To install this plugin in your Eclipse IDE:

  1. Go to Help > Install New Software... This should display the Install dialog box.
  2. Paste the Update Site URL (http://dist.sonar-ide.codehaus.org/eclipse/ the latest version or http://dist.sonar-ide.codehaus.org/eclipse-archives/ for previous ones) into the field Work with and press Enter. This should display the list of available plugins and components:


  3. Check the component you wish to install.
  4. Click Next. Eclipse will then check to see if there is any issue which would prevent a successful installation.
  5. Click Finish to begin the installation process. Eclipse will then download and install the necessary components.
  6. Once the installation process is finished, Eclipse will ask if you want to restart the IDE. It is strongly recommended that you restart the IDE.

You are now ready to configure SonarQube in Eclipse.

FAQ

Q: After the Eclipse restart I cannot see the Window > Preferences > SonarQube settings, but the SonarQube Eclipse plugin is listed in the installation details.
A: Could you try to restart Eclipse with the -clean flag?
  • No labels