Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 6 Next »

Module:

gt-coverage-multidim

Module Maintainer:

Daniele Romagnoli

Status:

(red star)(red star)v(star)(star)

Email Help:

Geotools-gt2-users@lists.sourceforge.net

Volunteer:

geotools-devel@lists.sourceforge.net

IP Review:

review.apt

The aim of this module is to define a new coverage framework which will allow to get access to multidimensional coverages (containing also Time and Elevation dimensions).

Module Status

The framework is actually composed of the main coverage-api module, the coverage-core, as well as several plugins to access multidimensional data such as, NetCDF, HDF4 and Grib.
All of them leverage on the Unidata NetCDF Java Library 4. (Actually supported formats: NetCDF, HDF4 (APS and Terascan Products), GRIB)

Gold Star Quality Assurance Check

(red star) IP Check: An header check is required and the review.apt file is missing for some modules.
(red star) Releasable: A few minor issues are present.
(star) Quality Assurance: Test Coverage is at the 60%.
(star) Stability: Based on the stable gt-coverage, gt-jdbc-h2, net.opengis.wcs modules.
(star) Supported: User Documentation can be found at the following link. The mantainer is active on the mailing list.

Module overview

Coverage API

The main module of the framework is the coverage-api which defines a set of interfaces to access coverages.

Coverage Core

This module provides default implementation for the coverage-api interfaces, as well as core objects used to handle spatio-temporal information exposed as metadata. 

ND-Plugins

Actually, there are 2 plugins implementing the framework:

  • GRIB
  • NetCDF

Unsupported Plugins

Two other plugins are present but not currently supported:

  • HDF4
  • GeoTiff

 

  • No labels