Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 44 Next »

Stable Release

Groovy 1.0 is the latest stable release.

Download zip: Binary Release | Source Release
Download unofficial Ubuntu/Debian package: Binary Release
Download Windows-Installer: Binary Release
Download tar/gz: Binary Release | Source Release
Download Javadoc: Javadoc zip

Once you've downloaded the distribution, please read the installation instructions.

Upcoming Release

Groovy 1.1-rc-2 is the latest milestone release of the next version of Groovy. Visit the Roadmap to find out further details.

Download zip: Binary Release | Source Release
Download unofficial Ubuntu/Debian package: Binary Release
Download Windows-Installer: Binary Release
Download documentation: JavaDoc and zipped online documentation

Maven Repositories

If you wish to embed Groovy in your application, you may just prefer to point to your favourite maven repositories or the codehaus maven repository. You should consult the individual pom files for the exact details but here is a summary of the main supported artifactIds and groupIds:

Groovy 1.0 stable release

Available in the Maven 1 and Maven 2 repositories.

<groupId>groovy</groupId>
<artifactId>groovy</artifactId>
<version>1.0</version>

Treats Antlr and ASM as standard dependencies. Only useful if you happen to also use the same versions of these jars yourself as it will save you having two copies of these jars. Dependencies mandated for all optional parts of Groovy, e.g. AntBuilder, GroovyMBeans, etc.

<groupId>groovy</groupId>
<artifactId>groovy-all</artifactId>
<version>1.0</version>

Includes jarjar versions of Antlr and ASM. Allows you or your other dependencies (e.g. hibernate) to use other versions of these jars. Dependencies mandated for all optional parts of Groovy, e.g. AntBuilder, GroovyMBeans, etc.

<groupId>groovy</groupId>
<artifactId>groovy-all-minimal</artifactId>
<version>1.0</version>

Includes jarjar versions of Antlr and ASM. Does not include any optional dependencies.

Groovy 1.1 milestone releases (1.1-beta-1, ..., 1.1-rc-1)

Available in the Maven 2 repositories.

<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy</artifactId>
<version>1.1-xxx</version>

Treats Antlr and ASM as standard dependencies. Only useful if you happen to also use the same versions of these jars yourself as it will save you having two copies of these jars. Optional dependencies are marked as optional. You may need to include some of the optional dependencies to use some features of Groovy, e.g. AntBuilder, GroovyMBeans, etc.

<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
<version>1.1-xxx</version>

Includes jarjar versions of Antlr and ASM and Commons-CLI. Allows you or your other dependencies (e.g. hibernate) to use other versions of these jars. Optional dependencies are marked as optional. You may need to include some of the optional dependencies to use some features of Groovy, e.g. AntBuilder, GroovyMBeans, etc.

<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all-minimal</artifactId>
<version>1.1-xxx</version>

Includes jarjar versions of Antlr and ASM. Does not include Commons-CLI or any optional dependencies. Not suitable by itself if you want to use any tools which do command-line processing, e.g. groovyc, GroovyShell, ...

In addition to the stable and milestone releases you can find intermediate SNAPSHOT releases at the codehaus snapshot maven repository.

Other ways to get Groovy

If you're on Windows, you can also use the NSIS Windows installer.

You may download other distributions of Groovy from this site.

If you prefer to live on the bleeding edge, you can also grab the source code from SVN.

If you are an IDE user, you can just grab the latest IDE plugin and follow the plugin installation instructions.

  • No labels