Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 9 Next »

Module Maintainer:

Simone Giannecchini

Status:

(warning) incomplete

Email Help:

Geotools-gt2-users@lists.sourceforge.net

Volunteer:

geotools-devel@lists.sourceforge.net

Recent Development

For the 2.2.x branch the coverage module has:

  • fixed some show stopping reprojection bugs
  • fixed some performance issues (used to burn memory, now it slightly singes it)

Module Status

The coverage module is incomplete but may be used for light work. You are warned however.

The coverage api is proceeding on a branch and may be progress is visiable based on the geoserver WCS branch. The uDig project is limping along based on what is in 2.2.x right now, but the result is only of limited utility, and they are exploring working with the OSSIM project.

The OSSIM project has binding as is interested in hooking in behind the new coverage API, giving everyone the best of both worlds (pure java, JAI, and straight C++ bindings).

If you have a chance to volunteer check out the coverage branch, I am sure simboss would love feedback from early adopters.

Outstanding Issues

The following issues (bugs and suggestions) have been raised on the geotools coverage module:

com.atlassian.confluence.macro.MacroExecutionException: JIRA project does not exist or you do not have permission to view it.

Since the geotools coverage model uses the interfaces from geoapi I am listing them here for reference:

com.atlassian.confluence.macro.MacroExecutionException: JIRA project does not exist or you do not have permission to view it.

History

The coverage API took a huge blow for the 2.1.x release where we replaced the CoordinateSystem class it was based on. It was dragged almost into usability by Richard Gould for the uDig 1.1. release. The API it was based on is from an OGC specification (called GridCoverageExchange), as much time was spent working on the parameters for this api as was put into using it.

Icon

Don't use GridCoverageExchange - use the Format objects directly!

However the OGC stopped supporting it, and work is underway to upgrade to a more stable ISO specification (see Coverage Implementation Central for current status).

  • No labels