Description

Provides better tooling integration with Eclipse. At the moment there is a single script that keeps Eclipse's classpath file up to date.

Installation

The current version of griffon-eclipse-support-plugin is 0.4.9
To install just issue the following command

griffon install-plugin eclipse-support

Usage

This plugin provides a single script which is automatically called whenever a plugin is installed or uninstalled. If you add/remove a library from $appHome/lib then you must manually run the script.

Configuration

Make sure to define the following classpath variables in Eclipse

otherwise Eclipse will complain that the jars cannot be located.

All source directories available under griffon-app and src will be automatically configured by the plugin. However, should you require additional source directories to be included you can do so by specifying a list of directories relative to the application's location. Add this settings to either BuildConfig.groovy or $GRIFFON_HOME/settings.groovy

eclipse.classpath.include = ['gen-src', '../app2/src']

Scripts

History

Version

Date

Notes

0.4.9

12-02-11

Fixes GRIFFON-436

0.4.8

10-21-11

Fixes GRIFFON-424

0.4.7

05-20-11

Fix a regexp problem on Windows platforms

0.4.6

05-20-11

Fix a regexp problem on Windows platforms

0.4.5

05-19-11

Fix a regexp problem on Windows platforms

0.4.4

05-19-11

Fix selection of kind = var | lib

0.4.3

04-15-11

Remove dependency on IVY2_CACHE env variable

0.4.2

04-06-11

Fixed GRIFFON-351 and GRIFFON-356

0.4.1

03-11-11

Fixed GRIFFON-180 (more tweaks)

0.4

02-15-11

Release sync with Griffon 0.9.2

0.3.1

10-10-10

Fixed GRIFFON-251

0.3

07-22-10

Release sync with Griffon 0.9

0.2.1

06-05-10

Fixed GRIFFON-203

0.2

05-30-10

Fixed GRIFFON-180

0.1

05-07-10

Initial release