While browsing the source code, SonarQube in Eclipse highlights issues. But its added value is to be able highlight the new issues that you have introduced while adding/modifying the source code. You can thus check your code prior to pushing it to the SCM to make sure that you haven't introduced any new issues.

Running an Analysis

To run a new analysis, right click on your project and go to SonarQube > Analyze. You can also hit Ctrl+Alt+Q wherever you are in your project to trigger a new analysis.

By default, the analysis mode is incremental. Because only new/modified files are checked, you get feedback and the list of new issues very quickly.

Note that you can also run an analysis on a working set. This allows you to trigger several analyses at once on all the projects of the working set.

Analysis Parameters

Parameters are retrieved as defined below:

Some plugins (useless for a preview analysis) can be skipped thanks to the sonar.preview.excludePlugins (was sonar.dryRun.excludePlugins prior to SonarQube 4.0) property. This property can be set through the SonarQube web interface: Settings > General Settings > General > General).

The default value is "devcockpit,pdfreport,report,scmactivity,views,jira". For example, to skip the Build Stability plugin (due to https://jira.codehaus.org/browse/SONARIDE-346), set the property to edevcockpit,pdfreport,report,scmactivity,views,jira,buildstability".

Last Analysis Date

There are two ways to know when the last analysis was run on a project:

Browsing the Issues

Four different views are available to browse the quality of your projects:

SonarQube Issues

The SonarQube Issues view displays the list of issues of the selected component (project, module, file, etc.). To display this view, go to Window > Show View > Other... > SonarQube > SonarQube IssuesProblems and Markers views also display issues.

Issues are flagged in the source code viewer. New issues (compared to the latest version on the SonarQube server) are highlighted in yellow. This allows you to focus on the new issues that you have introduced.

You can add/remove/order columns, group issues (by severity, new issues only, ...), filter issues (new issues only, issues assigned to me, ...), sort (by assignee, ...).

Note that "Resolved" issues are not displayed.

SonarQube Issue Editor

This view allows you to review the selected issue (add comments, confirm it, plan it, etc.) the same way you would do it through the web interface. To display this view, go to Window > Show View > Other... > SonarQube > SonarQube Issue Editor.

Note that it is not possible to review new issue that you have introduced.

SonarQube Rule Description

This view allows you to access the detailed description of the coding rule of the selected issue. To display this view, go to Window > Show View > Other... > SonarQube > SonarQube Rule Description.

SonarQube Web Browser

This view allows you to access the SonarQube web interface. This view is automatically displayed when clicking on SonarQube > Open in SonarQube server. It can also be displayed by going to Window > Show View > Other... > Sonar > Sonar Web Browser.

 

FAQ

No issues are displayed

It happens when the source folders are not properly set in Eclipse.

Let's take the C/C++ project sample for instance. When you import it into Eclipse, by default the source folder is set to /cpp-sonar-runner (and not to /cpp-sonar-runner/src):

Therefore, SonarQube will try to retrieve data from files whose fully qualified names are src/BiggestUnInt.cc, src/HelloWorld.cpp, etc. It will find none as the fully qualified names in SonarQube are BiggestUnInt.cc, HelloWorld.cpp, etc. (without "src/"):

Hence, you won't get any issue displayed in remote mode in Eclipse.

But if you set the source folder to cpp-sonar-runner/src instead:

you will get issues displayed: